Note: Due to the amount of SPAM received in the forums and to better serve our customers, support is now done by sending a message using the "Contact" link above . This forum is set to read-only, but you can still search the forum.

Welcome, Guest
Username: Password: Remember me
Zap Weather Bug Report

TOPIC: Cron error from cronzeather

Cron error from cronzeather 9 years 2 months ago #1264

  • jwill
  • jwill's Avatar
When running any of the following Cron commands

"/home/account/cron/cronzweather riversidesnowbirds.com"
"/home/rivers13/cron/cronzweather www.riversidesnowbirds.com"
"/home/rivers13/cron/cronzweather www.riversidesnowbirds.com"

(the previous line has http:// but it doesn't appear in the message.)


I receive the following error message from cronzweather

"invalid syntax for command, should be ' www.yourdomain.com'"

Any suggestions or ideas?

Jim
Last Edit: 9 years 2 months ago by jwill.
The administrator has disabled public write access.

Re:Cron error from cronzeather 9 years 2 months ago #1278

  • TupeloWx
  • TupeloWx's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 42
  • Karma: 0
Try this:
/usr/bin/php -f /home/account/public_html/cron/cronzweather www.yourdomain.com
The administrator has disabled public write access.

Re:Cron error from cronzeather 9 years 2 months ago #1279

  • TupeloWx
  • TupeloWx's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 42
  • Karma: 0
... http:// should appear before the www
It is being left off when posting.
The administrator has disabled public write access.

Re:Cron error from cronzeather 9 years 2 months ago #1282

  • jwill
  • jwill's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
Received the same error message with this command:

invalid syntax for command, should be ' www.yourdomain.com'

I also tried "cd /home/account/public_html/cron/ php -f cronzweather www.yourdomain.com

I was able to get a phplist cron job working by using a curl command that I found but I don't know how to format the zweather cron command to work with curl.

Jim

P.S. - "html://" was deleted again by the message editor

TupeloWx wrote:
Try this:
/usr/bin/php -f /home/account/public_html/cron/cronzweather www.yourdomain.com
The administrator has disabled public write access.

Re:Cron error from cronzeather 9 years 1 month ago #1298

  • jwill
  • jwill's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 3
  • Karma: 0
After trying every possible solution I can think of, I have given up trying to pass an argument through a cron job.

Since I only have one site, I eliminated the URL argument in the cron command and eliminated the loop in cronzweather and hard coded the URL. That works.

Jim
The administrator has disabled public write access.
Time to create page: 0.028 seconds
Powered by Kunena Forum